Game Questions & Answers
iPhone - iPod

The Secret Society: Hidden Mystery Answers for iPhone - iPod

Home / iPhone - iPod /

Game Questions & Answers (Q&A) service lets you ask questions about video games for game consoles or PC games. So ask your The Secret Society: Hidden Mystery question for iPhone - iPod and get answers from real gamers or answer questions and share your insights and experience with the rest of the gaming community. Note: This apple iPhone game app may also be compatible with the game app for apple iPad.

Boxshot / Details
The Secret Society: Hidden Mystery Cheats Boxshot
  • Developer: G5 Entertainment
  • Publisher: G5 Entertainment
  • Genre: Adventure General
  • Release Date: Nov 21, 2012
  • ESRB: Not Set

Question & Answers

Can't complete collections anymore (Closed)

I have all the items needed to collect every collection, but when I try to combine I get the message "You haven't completed the collection". (All four are complete but none will combine).

Ang, Aug 19, 2013, 20:23 PM
Answers

Answer from: strongdar
I would guess you don't have all the elements needed to combine the collection; you need more than just the 4 or 5 items that make up the collection.

Posted: Aug 20, 2013, 8:27 AM

Answer from: charisma 7ivner
@ Ang. im having the same problem combining collections to get the artifacts. is that what you meant also? or are you not able to finish any collections? before this last update when you clicked on any end collection item it didnt say what it says now. it says that we can "get random elements to charge the artifacts". so if anyone knows how to finish these artifacts or what we're supposed to do now PLS let us know. thx

@ Strongdar. Do you know what other items we would need now besides the 5 listed in each row of collections that we didnt need before?

Posted: Aug 20, 2013, 9:36 AM

Answer from: Ang
I have all the elements needed and all the items. I actually have enough of all to complete all four artifacts at least twice. This began shortly after the update.

Posted: Aug 20, 2013, 12:59 PM

Answer from: One
Was your "sorting" option turned on? I have had that problem, too, and I'm wondering if the problem occurs when the sorting option is turned on. I had noticed that my collections had the wrong names, so now I've turned off.

Posted: Aug 20, 2013, 13:23 PM

Answer from: Monkey
I am having the same issue. I have collected all necessary collections for an artifact and have the necessary amount of tools to complete, but I am getting a message saying that I have not completed the collection. Mine also began happening after the last update.

Posted: Aug 20, 2013, 15:12 PM

Answer from: charisma 7ivner
Hey guys it finally let me combine the artifact collections. i dont know what exactly did it but i clicked on everything. i clicked each collection and the tools needed to combine them and the end product or actual artifact and then it let me do it. hopefully itll work for someone else.

Posted: Aug 21, 2013, 1:59 AM

Answer from: kiki
@charisma, it worked for me too!

Posted: Aug 21, 2013, 6:53 AM

Answer from: Grey
Apparently, because I do not have an open ended wrench, I cannot do it. Even though I have the collection

Posted: Aug 21, 2013, 17:15 PM

Answer from: Bellydancer
I tried the suggestion posted by One and it worked! Couldn't combine while Sort was enabled, but as soon as I disabled it by unchecking the box, I was able to combine collections and artifacts. Thanks, One!

Posted: Aug 23, 2013, 8:49 AM

Answer from: Grey
Ok. I spent a gem and got one of the items. I had 58 of them already and only needed one, but I was able to build the time talisman again.

Posted: Aug 24, 2013, 9:41 AM

Answer from: Anne
All you have to do is click on the box with the collection items in and it will turn from brown to green and then you can make the collection

Posted: Aug 26, 2013, 16:15 PM

Answer from: Beebz
I'm having this problem and have tried every suggestion on this site. I have everything required to combine the collection but I keep getting the message "you haven't completed the collection" anyone help?

Posted: Sep 4, 2013, 8:19 AM

Answer from: Cleaver
@Beebz: In Artefacts, click on the wands and clock face above the word "complete." That should turn the brown to green.

Posted: Sep 5, 2013, 16:15 PM

Answer from: Dew
It's a combination of events to collect Artifacts. Must first uncheck the "Disable sorting", then click on each of the wands and clock face in the box above the word "complete". (Just as "Cleaver" indicated in their post. Thanks to all for posting on this site. It was a tremendous help!

Posted: Sep 7, 2013, 20:11 PM

Answer from: Dillybobsnan
That is the solution. Press each item above the word combine .Doesnt make sense but it worked

Posted: Sep 9, 2013, 20:40 PM
All Questions Ask a Question
Videos You May Like...
View All Videos
Game Related Options