Game Questions & Answers
iPhone - iPod

The Secret Society: Hidden Mystery Answers for iPhone - iPod

Home / iPhone - iPod /

Game Questions & Answers (Q&A) service lets you ask questions about video games for game consoles or PC games. So ask your The Secret Society: Hidden Mystery question for iPhone - iPod and get answers from real gamers or answer questions and share your insights and experience with the rest of the gaming community.

Boxshot / Details
The Secret Society: Hidden Mystery Cheats Boxshot
  • Developer: G5 Entertainment
  • Publisher: G5 Entertainment
  • Genre: Adventure General
  • Release Date: Nov 21, 2012
  • ESRB: Not Set

Question & Answers

Cannot unlock Gem Match

It says i need pieces of the gem match puzzle to unlock it, but i have 4 of them in my inventory. I have a ton of quests that i can only complete by playing Gem Match, but can't! HELP! thank you!

Beazus, 9 months ago
Answers

Answer from: Zecret Zociety
It was so long ago I can't remember how I did this - I assume it was like the pictures where I clicked on it and then paid coins to open it once I'd collected the pieces. Is it a task on the side of your screen? Try pressing it and then tap hints, hopefully it will show you what to do then.

Posted: 9 months ago

Answer from: Beazus
Its not one of my quests on the left yet, but i wasnt sure if something was wrong because at least six of my current quests need Gem Match to progress. just super frustrated!! thanks for your help!

Posted: 9 months ago

Answer from: Ann
I can't remember either! Did gem match come with Christmas update? Have you done all the updates? Is there a picture of a lock on the game? Is the lock open?

Posted: 9 months ago

Answer from: Beazus
The lock is open on the photo! But that is as far as I have gotten.

Posted: 9 months ago

Answer from: Thekettlewitch
Same for me. Have a list of quests needing the to solve gem match, lock is open, four gems in inventory. If I click on the picture it says to unlock I need to use 40 crystals plus some coins.

Posted: 9 months ago

Answer from: Beazus
I ended up buying crystals and unlocking it. too frustrating.

Posted: 9 months ago

Answer from: Aashi
Anyone solved this? I'm at exactly the same stage. Got 4 of the pieces in my inventory. Any chance I need more?

Posted: 8 months ago

Answer from: Lumcs
I need one more piece but no joy?!

Posted: 8 months ago

Answer from: Daveg
Seems that lots of folks have this unlocked yet no one has posted where to find the last gem. I don't want to pay a 40 crystal price. Can someone who has this unlocked please share with us who don't?

Posted: 8 months ago

Answer from: Argh
I suspect it is a glitch that the last gem piece isn't appearing in pictures for those who downloaded the game after the Christmas update.

Make sure you definitely don't have a quest for it (in your list of quests on LHS of the screen). If you do have a quest, then use show hints to find out where to get the piece. If you still have any Christmas quests (they will have decoration around circle in quest list and ask you to investigate Christmas Eve) you might need to work through them to see if a quest for finding the match-3/Gem match pieces comes up, as unlocking that game was originally part of the Christmas quests so you might simply be too early in that sequence of quests to find the pieces.

If you do not have a quest, and do not have any Christmas quests left then it is definitely a glitch in your game. You could go through each picture/puzzle and look at their research windows to see if the piece is in the 'can be found' list. If there is not sign of it in any picture/mode than you can either wait for G5 to respond to your queries or use crystals to unlock it.

If you choose to use crystals to unlock it, are at a low enough level, and have less than 60 crystals there is another glitch in the game that could help you. Go to your friends and look through their wishlists for combining elements that you are at too low a level to send. (If you scroll through the 'send a gift' tab when on the gifting screen you can see which elements you can send and which require a higher level). Then find one of the items you can't send on any friends wishlist - and press it like you would to send something you can send/have. It will tell you it will cost you crystals to unlock. Press yes, and it will send the element, your crystals will be deducted (if you have less than required amount this still works, in fact that is the best situation to be in). Visit a friend, and when you leave the friends tab you will see your crystals are now at 60. Unlock the game with those, go back into your friends and find another element you are not at high enough a level to send, send it from a wishlist, then visit someone, and when you come back out of the friends section you will be at 60 crystals again.

It is only a matter of time before G5 close that particular loophole, so best to do it quickly.

Posted: 8 months ago

Answer from: Daveg
Thanks Argh.. Now have access :)

Posted: 8 months ago

Answer from: Frustrated!
Thanks! Worked for me too...

Posted: 8 months ago

Answer from: Ohboy
Don't do the cheat... apparently G5 figured it out and it will now put you in the negative on gems...

Posted: 8 months ago

Answer from: AmBeTh
Thank you, Argh!

Posted: 8 months ago

Answer from: Shorty
Ohboy, It does show a negative on your gems at first. You need to visit the friend that you sent the gift to after you "purchase" the item. When you get back from visiting then you have 60 crystals in your account.

Posted: 8 months ago

Answer from: Argh
Hi OhBoy, I have just double checked it on secondary account. You must not leave the friends section after you send the gift. You have to visit someone first. It doesn't matter if it is the friend you sent gift to or another friend, but you have to do it all at once: gift then visit. Or yes, you will be in minus crystals. I got down to -161 when testing the order and when I gifted then visited it immediately went back to 60. I visited the friend next to the one I gifted. Also I use all my daily charges when visiting but that isn't necessary, just polite.

Posted: 8 months ago

Answer from: Manask9
Thanks to all...it does work

Posted: 8 months ago

Answer from: Sapstitch
Didn't understand the directions at first and I didn't have too many friends to choose from but i got lucky with one and this totally worked. Thanks so much now I can gem match and move on with the quests.

Posted: 8 months ago

Answer from: Tracey
Hi all, Have they closed that glitch? I got some new friends so I could use that cheat, and 2 days later I can no longer do it! Ah well good while it lasted :)

Posted: 8 months ago

Answer from: Argh
Hi Tracey - I've just tested it there and glitch still working on my secondary game. Honestly, I think it's the sort of thing that needs an update to fix, not a patch sent across the servers, but I could be wrong, it is a simple real number error. So maybe it will be gone before the next update. I will check whenever someone posts here that it's not working, as I don't really open that game much and my main game is too high a level. One thing you should be careful about - I find it does not always work if the 'purchase' doesn't take you into minus crystals. So you need to make sure you spend enough before doing it each time. Because the going into minus crystals is the glitch (you shouldn't be able to go into debt in the game!) it might be necessary to go into minus to get the total to reset back to 60. Also make sure you visit someone before exiting the friends section.

Posted: 8 months ago

Answer from: Tracey
Thanks Argh, maybe it was just a strange circumstance yesterday.

Posted: 8 months ago

Answer from: Tracey
Ok, thanks Argh. And HUGE thanks for the suggestion, I forgot to say in my excitement :)

Posted: 8 months ago

Answer from: SallyJonz
I have all 4 pieces, and no quests (a victim of the post-Xmas glitch!). I decided to try Argh's crystal-snagging suggestion, but when try to give the gift (that I'm at too low a level and with not enough crystals to send) the game just tells me I have to go to the bank to get more, and won't let me send and go into negative. Help Argh! Am I doing something wrong, or has G5 caught up with the loophole?

Posted: 8 months ago

Answer from: Argh
Hi SallyJonz, I think you might be trying to give the gift from the 'send a gift' tab instead of the friends wishlist. When you go to your friends section, choose a friend and press 'send a gift' under their name a window pops up that has three sections. The main area of window open along the bottom is the 'send a gift' tab, which contains all the combining elements. This is where you send free gifts from. You can toggle between this tab and the 'send a collection item' tab which shows all the collection items in your inventory which you can send from your inventory. Above these is a small picture of your friends avatar, and next to that are 5 slots that show your friends wishlist. You need to press the combining element in your friends wishlist, not in the 'send a gift' tab. If you know what the combining elements look like, go through your friends and look at these 5 slots in their wishlist. What you want is a friend that you have not given a free to yet today, who has an item in their wishlist that you know is a combining element (not a collection item) where this item does not have a '1' in the top right corner. This is a locked item due to your level being too low (if you already sent the friend a combining element that day they will all have no number in top right corner as you are restricted to 1 free gift a day).

Posted: 8 months ago

Answer from: Argh
So find a combining element with no number in wishlist and press it's icon on the wishlist. A message will come up entitled 'insufficient level' telling you you need to be level X to send that item but you can unlock it now for X crystals. Press okay. It will deduct those crystals from your bank and give you confirmation that gift was sent. The gifting window will automatically close and you will be back looking at your friends list. Do not exit the friends section, instead press the visit button under that friend or another friends avatar and visit their board. When you leave their board and then the friends section and return to your own board you will have 60 crystals in your bank IF you had less than X crystals to begin with (so the purchase drove you into minus crystals). I've doubled checked and this still works on an iPhone this morning. I cannot speak for other devices.

Posted: 8 months ago

Answer from: SallyJonz
TaaDaa! It worked. Thanks so much Argh, your clarification was spot on. Now I can also tell you that your workaround works from an ipad too. Gem Match all unlocked, and a few spare crystals too!

Posted: 7 months ago

Answer from: Argh
No problem, happy to help. Thanks for letting me know.

Posted: 7 months ago

Answer from: Sggggggg
Hi all. I took JJJ and Arghs advice on my other thread and submitted a support request to G5 support. Resolution took about a week...read below. Here is what happened. After answering the standard questions of device etc, providing some screen shots of the affected Gem Match items and finally providing an invite code to them, they provided me a gift of 40 crystals to use to unlock my Gem Match game. I did ask if this glitch will be fixed in the next update and received a response back today saying that the fix is coming in the next update. DebLBugs reports on April 15 that the update is coming in the next week. If by some chance it is not fixed and the glitch fix above provided by others no longer works, then I suggest trying the formal support route to G5 to make sure they remain informed. Hope this helps...and if not needed...all the better

Posted: 7 months ago

Answer from: Argh
Thanks for posting this Sggggggg - it is very interesting (particularly the steps you had to go through). I am glad you got the game unlocked, and hopefully this will be fixed in the next update The glitch fix definitely will be, and to be honest I posted that glaring glitch all over posts about the gem match problem on purpose, hoping that they would see it. I knew they would definitely close that loophole as quickly as possible, so by putting it next to the much bigger problem maybe they would also see that and fix both. It was the only thing I could think to do, since I don't have the problem myself, so couldn't do what you did and simply show them.

It is great that you contacted G5, I think sometimes people don't do that. And they can't fix something they don't know is happening, so by you giving them access to your game they could see that is really is a bug and something that needs to be fixed. I think they will have this fixed soon now, but they never would have if it wasn't for you and any one else experiencing this who took the time to contact them. Nice one!

Posted: 7 months ago

Answer from: Zme
Argh: We are not friends yet, but just wanted to say thanks for the info!

Posted: 7 months ago

Answer from: Tfstr
Thanks argh! Your suggestion worked for how to get the 60 crystals to unlock the gem match :)

Posted: 7 months ago

Answer from: Pctk
Thanks so much to Argh!

Posted: 6 months ago

Answer from: Rose
Didn't work for me... I guess they fixed the glitch already. Now down crystals...

Posted: 6 months ago

Answer from: Argh
Hi Rose, I have just checked this on an iOS game that has been updated to the 1st tavern update (version 1.9) and it still works. I recently got confirmation that it works on a kindle that is on Valentines Update (since tavern update not available to android/kindle yet). So as far as I can tell the loophole has not been closed on versions 1.9 or lower. I can't check the second tavern update (1.9.5) as I want to keep that game on lower update to keep an eye on coin glitch.

However, when you say you lost crystals, it shouldn't be possible to lose crystals doing the method, as it involves attempting to make a purchase for more crystals than you currently have. If glitch is fixed, you will just be offered to buy crystals in the bank, you can't be charged more than you have.

Perhaps you could try the above instructions again, but make sure that 1) you only try to make the purchase by attempting to send a locked item from a friends wishlist and not the send a gift tab, 2) that the price to unlock the combining element is more than your current crystals total (so you can't lose any if doesn't work) and 3) that you immediately visit a friend after making purpose, without leaving friends section first it must be gift then visit then return to your home desktop.

Posted: 6 months ago

Answer from: Sam123
As I posted somewhere else on this board, when I had this problem recently I had a friend send me a duplicatenof one of the gems I already had and it unlocked. My post here is to say "GREAT JOB AND PATIENCE " to Argh. I am learning so much from your detailed posts.

Posted: 5 months ago
Answer this Question
Don't Post New Questions Here... For New questions Click Here
All Questions Ask a Question
Videos You May Like...
View All Videos
Game Related Options