Game Questions & Answers
iPad Games

The Tribez HD Answers for iPad

Home / iPad /

Game Questions & Answers (Q&A) service lets you ask questions about video games for game consoles or PC games. So ask your The Tribez HD question for iPad and get answers from real gamers or answer questions and share your insights and experience with the rest of the gaming community.

Boxshot & Details
The Tribez HD
  • Developer: Game Insight, Llc
  • Publisher: Game Insight, Llc
  • Genre: Adventure
  • Release: Apr 3, 2012
  • ESRB: Not Set

Question & Answers

Getting sand pit

When does the quest for the sand pit come up

mattj, Jun 23, 2012
Answers (Closed)

Answer from: Bman02
U should get it when you find 5 spears from murloids and 3 diamonds from gold chunks and 1 disc in the UFO the quest should be find things

Posted on: Jul 12, 2012

Answer from: Kelly
I've found all the items mentioned above and still not able to build a sand pit. What else is there to do?

Posted on: Jul 28, 2012

Answer from: Roody003
I'm currently waiting to build the sand pit too. I have to complete another quest (find Gravisnatch, find translocator, and Mutaplasm containers (these are taking the longest) in the UFO after completing the first quest to find 5 spears from murloids and 3 diamonds from gold chunks and 1 disc in the UFO the quest. this quest is taking forever ( i refuse to spend money to buy gems)

Posted on: Aug 18, 2012

Answer from: Rike2339
You have to upgrade 3 Villas on Mystery Shore in order for the "find items" quest to appear along with the quest to build the Sand Pit.

Posted on: Aug 18, 2012

Answer from: Zenobio
After you get the items from the UFO, you have to do a quest where you upgrade your villas. after I did that the sand pit quests opened up.

Posted on: Aug 18, 2012

Answer from: DG
The quest for the mutaplasm and stuff from the ufo is taking forever for me too. I believe that between updates if you had started the quest looking for items before getting to the villa quest then it won't work. If you finish the villa quests then the item quest should begin to work again.

Posted on: Nov 18, 2012

Answer from: rcb
I think finding the mutaplasm in the UFO is linked to the amount of Marble you have. Nothing happened after endless searching the UFO. I pushed my production of the Marble and then found the mutaplasm.

Posted on: Nov 20, 2012

Answer from: TT
You have to wait until the quest to build villa appears. Build three of them and upgrade until level 2. Then the quest to find shovel will appear and that's the quest needed to build sand pit. I'm lazy to wait for the time and not willing to buy more gems. What I did is cheat the time. Go to setting/date and set your time half an hour faster. Then go back to the game. Collect all the money and resources. Set all the worker and go back to setting and set the time half an hour faster again. I repeat it several time and it worked very fast :-) But after about 10x, there will be a message on the game that say you are cheating. I don't care. The game still on and i'm happy with the result. In half day time, I finish my villa and the quest to find shovel came out. So happy about it..... Good luck.

Posted on: Jan 10, 2013

Answer from: Sad leon
Time cheat killed my game : ( dont trust those who advise it. i had four islands, it had taken me since christmas when i got my ipad and tribez.

Posted on: Mar 27, 2014
Ask / All Questions »
Trailers & Gameplay Videos
The Tribez HD

The Tribez HD - Gameplay Video

More Options
Games You May Like