Game Questions & Answers
iPhone - iPad Games

The Simpsons: Tapped Out Answers for iPhone - iPad

Home / iPhone - iPad /

Game Questions & Answers (Q&A) service lets you ask questions about video games for game consoles or PC games. So ask your The Simpsons: Tapped Out question for iPhone - iPad and get answers from real gamers or answer questions and share your insights and experience with the rest of the gaming community.

Boxshot & Details
The Simpsons: Tapped Out
  • Developer: Electronic Arts
  • Publisher: Electronic Arts
  • Genre: Strategy City Building
  • Release: Mar 1, 2012
  • ESRB: Not Set

Question & Answers

I'm stuck on squidport pt 5

How can i get past squidport part 5? I'm stuck there and it wont continue on with the rest of the stuff. Also how do I get Kang and that limo in moe's suit quest?

ants, Jun 17, 2013
Answers (Closed)

Answer from: Mj
I was stuck, put the itchy scratchy building in inventory, took it back out and placed on squidport again and Quest came up complete.

Posted on: Jun 18, 2013

Answer from: Harwood88
Same here :( it's annoying

Posted on: Jun 18, 2013

Answer from: smitty
Put it in your warehouse then replace it. That worked for me.

Posted on: Jun 19, 2013

Answer from: jcarson4
The update today solved this issue

Posted on: Jun 19, 2013

Answer from: speedracer333
I had the same problem and today it let me continue on when i turned my game on. Not sure why i was stuck but it is unstuck now.

Posted on: Jun 19, 2013

Answer from: Expert
You can't get them without hacking. They were only available during Halloween and Moes suit episode. You can try next Halloween

Posted on: Jul 4, 2013

Answer from: Jor23
I cant start part 5 on squidport it's getting. Annoying im level 22 and have bought 3 water expansions please help!

Posted on: Apr 10, 2014
Ask / All Questions »
Trailers & Gameplay Videos
View All Videos »
More Options
Games You May Like