Game Questions & Answers
iPhone - iPad Games

100 Floors Answers for iPhone - iPad

Home / iPhone - iPad /

Game Questions & Answers (Q&A) service lets you ask questions about video games for game consoles or PC games. So ask your 100 Floors question for iPhone - iPad and get answers from real gamers or answer questions and share your insights and experience with the rest of the gaming community.

Boxshot & Details
100 Floors
  • Developer: Tobi Apps Limited
  • Publisher: Tobi Apps Limited
  • Genre: Adventure
  • Release: May 4, 2012
  • ESRB: Not Set

Question & Answers

Stuck on floor 86

Anyone help me. Please!

Tong, Jun 23, 2012
Answers (Closed)

Answer from: forfloor86
If you click the number you see that two of them will rotate differently then the others. (11 and 8 rotate left) so turn the hand on the clock left to 11, right to 5, right to 1, left to 8, and right to 12

Posted on: Jun 23, 2012

Answer from: rivall
I tried this, even followed you tube movies, but the door won't open...Help!

Posted on: Jul 29, 2012

Answer from: floor86 is brok
I am using an android and have the same problem. I know it is correct. I hit the button and rotate the clock the clock in the same direction to the appropriate time. I do not go past or do any extra anything. I have watched the video and do exactly that, their door opens, mine does not. This must be a glitch.

Posted on: Jul 30, 2012

Answer from: Andy P
For those that are stuck, be aware that if you overshoot even a little and backtrack to the spot on any of the numbers, the door won't open. You have to get to the spots precisely. I found a stylus to make things easier.

Posted on: Aug 1, 2012

Answer from: Sin
Turn the hand first then press the corresponding number. Ie turn right to 11 the press the 11 button

Posted on: Aug 1, 2012

Answer from: Floor 86
I think floor 86 is broken I watched lots of videos on you tube still no luck

Posted on: Aug 3, 2012

Answer from: Rhii
Move the clock hand first then press the number for example turn the clock hand to 11 then press the 11 this helped me heaps it works

Posted on: Aug 5, 2012

Answer from: HK
Still doesn't work for me either. Also on Android. Tried several combos, being very careful. Anyone have any luck?

Posted on: Aug 5, 2012

Answer from: gal
I know the answer!!! Push all the buttens, and just then move the clock. While moving the clock, keep your finger on the screen the whole time. Wait 10 second between each number. Sorry for the bad English, but it's realty working!!

Posted on: Aug 5, 2012

Answer from: Wolf21MG
Android has a slight problem. You'll have to wait for the update on 100 floors to fix it.

Posted on: Aug 5, 2012

Answer from: afriend
On android i restarted and made no mistakes my first try. restart as in press the restart button on the bottom right

Posted on: Aug 7, 2012

Answer from: jak
I had same problem on Android. Gal's solution works.

Posted on: Aug 8, 2012

Answer from: highlander
The right thing to do is to turn the number one two times and also two times the number 12

Posted on: Aug 8, 2012

Answer from: scrappy
I had same problem on Android too & Gal's solution worked for me after trying all other possible solutions, combos, etc. Thank u Gal!

Posted on: Aug 9, 2012

Answer from: Sub
Press each number 2 times before setting the clock. Worked for me. Gals solution would not work for me either.

Posted on: Aug 12, 2012

Answer from: rhine
Im on android too and gals solution works except that i dont have to hold it for 10 seconds... press all the buttons and remember how they rotate, also make sure to refresh the level before you start, the 11 only has to go two clicks counterclockwise from 12 - hold it for about 3 secs and dont release your finger then rotate clockwise to 5 then so on

Posted on: Aug 12, 2012

Answer from: Sasha
For me solution was to press corresponding number after each turn (iPhone user).

Posted on: Aug 15, 2012

Answer from: cougar
Im on DROID and i had to push each # twice then go to each # correctly.

Posted on: Aug 18, 2012

Answer from: Matt
Push all the numbers at the top to see which way you turn the hand on the clock. After figuring out the sequence rotate the clock hand to each one of those numbers without lifting your finger off the screen.

Posted on: Aug 22, 2012

Answer from: Neves
Pushing every button first then moving the clock in the correct way without taking my finger of worked thanks matt

Posted on: Aug 23, 2012

Answer from: roads
Push the 11...see that you rotate counterclockwise to 11...push the 5...rotate clockwise to 5...push the 1...rotate clockwise to 1...push the 8...rotate counterclockwise to 8...push the 12...rotate clockwise to 12. you can take your finger off the clock.

Posted on: Aug 23, 2012

Answer from: The happy one!
I've got the IPhone and found keeping the phone upright the whole time worked. The sequence that worked for me was pressing each number once in order from left to right, then moving the hand to the correct number either clockwise or anticlockwisewise, depending on which way the number At the top went! Hope it helps! :-)

Posted on: Sep 12, 2012

Answer from: Cheche
U have to turn 11 counter-clockwise 2x

Posted on: Oct 19, 2012
Ask / All Questions »
More Options
Games You May Like