Game Questions & Answers
iPhone - iPad Games

Virtual Families 2: Our Dream House Answers for iPhone - iPad

Home / iPhone - iPad /

Game Questions & Answers (Q&A) service lets you ask questions about video games for game consoles or PC games. So ask your Virtual Families 2: Our Dream House question for iPhone - iPad and get answers from real gamers or answer questions and share your insights and experience with the rest of the gaming community.

Boxshot & Details
Virtual Families 2: Our Dream House
  • Developer: Last Day Of Work
  • Publisher: Last Day Of Work
  • Genre: Simulation Virtual
  • Release: Dec 6, 2012
  • ESRB: Not Set

Question & Answers

Is there a glitch in the praise for pulling a weed?

One of the goals is to praise for pulling a weed but on my game it wont accept the praise. It worked for one of my daughters games but not mine and my other daughter is there a glitch and or a update to fix it?

vivdblue, Dec 27, 2012
Answers (Closed)

Answer from: Horsegirl
I have also been trying to do that and it has not worked for me either, I think it is a glitch. Just keep trying it might work eventually.

Posted on: Dec 28, 2012

Answer from: Bailey875
I am a few generations in and everytime they pull a weed I praise them and I still haven't unlocked that goal.

Posted on: Jan 2, 2013

Answer from: NM
I had to praise them twice while he was polling the weed for it to accept the praise.

Posted on: Jan 4, 2013

Answer from: Cooly
I tried to do that to but it won't accept, I did it many times but it doesn't work. I think that they will have an update soon.

Posted on: Jan 5, 2013

Answer from: Jessica17
Same here. I think its just a glitch

Posted on: Jan 6, 2013

Answer from: Glitches
Yup there probably is one because it happens to me all the time

Posted on: Jan 6, 2013

Answer from: Jaded14
Yea there are a few glitches especially in the 3rd floor/level of the house :( I hope they bring a update out soon, I can't even use the 3rd floor- what a waste of a room renovation :(

Posted on: Jan 7, 2013

Answer from: Glitches
Not anymore if you have a iPad or iPod you probably got the update and they fixed the glitch

Posted on: Jan 18, 2013

Answer from: teddygirl
I have a kindle fire and it worked for me the first time.

Posted on: Dec 3, 2013

Answer from: Tuttle power!
Teddygirl I have a kindle fire too it worked for me the first time too.

Posted on: Mar 30, 2014
Ask / All Questions »
Trailers & Gameplay Videos
View All Videos »
More Options
Games You May Like