Game Questions & Answers
iPhone - iPad Games

Ravensword: Shadowlands Answers for iPhone - iPad

Home / iPhone - iPad /

Game Questions & Answers (Q&A) service lets you ask questions about video games for game consoles or PC games. So ask your Ravensword: Shadowlands question for iPhone - iPad and get answers from real gamers or answer questions and share your insights and experience with the rest of the gaming community.

Boxshot & Details
Ravensword: Shadowlands
  • Developer: Crescent Moon Games
  • Publisher: Crescent Moon Games
  • Genre: Role-Playing Action RPG
  • Release: Dec 20, 2012
  • ESRB: Not Set

Question & Answers

Stuck in Citadel do Ror-Dan

I moved the blocks, and jumped over the green liquid. I received the gem, rune of force from the room. I also got the other gem from another room. I'm still unable to open the last door. When I stand at the entrance of the last room (where the green liquid was) the door opens, and then closes as soon as I move closer. I've tried moving a block to hold the door open, that didn't work. I tried moving the block to the other side of the room to keep the door open, that didn't work. I tried opening the door from the other entrance that dint work. What am I not seeing. Can any one help me?

Sunrize1, Jan 3, 2013

Answer from: elenrod
You have to move the block to the other side of the room right before the entry way. it is a bit of raised tile. that will keep the door open.

Posted on: Jan 4, 2013
Answer this Question
Ask / All Questions »
More Options
Games You May Like