Game Questions & Answers
iPhone - iPad Games

The Secret Society: Hidden Mystery Answers for iPhone - iPad

Home / iPhone - iPad /

Game Questions & Answers (Q&A) service lets you ask questions about video games for game consoles or PC games. So ask your The Secret Society: Hidden Mystery question for iPhone - iPad and get answers from real gamers or answer questions and share your insights and experience with the rest of the gaming community.

Boxshot & Details
The Secret Society: Hidden Mystery
  • Developer: G5 Entertainment
  • Publisher: G5 Entertainment
  • Genre: Adventure
  • Release: Nov 21, 2012
  • ESRB: Not Set

Question & Answers

Update related Gem Match glitch

Hi folks, I updated recently (iPad) and since that time, I can't play Gem Match. When I try, it takes my energy points and looks like it's going to work, but then the screen goes black (for a long time) and the only way I can get out of it is to quit the game and start over. My energy points are gone; don't know whether or not it breaks my streak, as I'm still working my way past an earlier disaster. Any suggestions? My wife, also playing on an iPad, does not have this problem with hers. Thanks for the help. Ernie

Ernie, May 6, 2014
Answers (Closed)

Answer from: Argh
Hi Ernie, I haven't seen this on either of my devices with the update (ipad and iphone). Have you tried force quitting the game and restarting your device? Double tap the home button on your ipad to bring up all open apps, and then depending on which ios you have quit the app be either swiping the large picture of the game upwards on ios 7 or above, or by holding the app icon until it wobbles and pressing the red dash that appears in top left corner if on ios6 or below. Then turn off your ipad and wait a few minutes before restarting. It is never a good idea to play an updated app without restarting after you update. Hopefully this will clear the gem match problem. Also make sure to not have any other apps running when playing SS, quit everything else using above instructions before opening the game.

The Valentines update introduced a glitch into Gem Match by accident, which meant that anyone that downloaded the game for the first time after the Valentines update could not actually open the game due to a missing puzzle piece from their inventory. They promised a fix with the next update, and the tavern update did indeed fix this problem. On my test game with the glitch I was finally able to open gem match after I updated. The reason I am telling you this is because in order to fix that glitch it is very likely the developers worked on the Gem Match games code and added to it for the Tavern update, which might explain why you are now experiencing problems with the game. The solution to the other glitch was simple - enough people needed to tell G5 what was going on so they would be aware of the problem and fix it. The same applies to your problem if a device restart doesn't sort it out. The best thing you can do for your game, and for anyone else experiencing this problem is to contact G5 directly and tell them about it. They can only fix problems they know about. Go to the offical G5e website for this game (google secret society G5 games and look for G5e url), press the big green 'Support' icon at the top of the page, and then select the 'submit a request' tab at the top of support page. Be sure to be as detailed as possible in the ticket, mentioning that it has started since the latest update.

Posted on: May 7, 2014

Answer from: Pauly
What ios are you on? Your wife?

Posted on: May 7, 2014

Answer from: Nitey4ever
Restart iPad. Make sure you have NO other apps open. Beyond that, I'm not sure.

Posted on: May 7, 2014

Answer from: Barb
I am having the same issue! I was not affected by the Valentine update glitch. I have restarted my iPad but that did not fix the issue. I have emailed support and told them of the problem.

Posted on: May 7, 2014

Answer from: Ernie
I tried the reboot thing, too, and it didn't fix it for me, either. I guess my next step is to email support. Thanks Barb, Argh, and others for the suggestions. Ernie

Posted on: May 7, 2014

Answer from: Della
Add a "me too" to this issue. I've wasted a ton of energy points trying to see if it is fixed. I've emailed support. If I get an answer from them, I'll let y'all know here.

Posted on: May 10, 2014

Answer from: JJJ
Try this, I do this whenever the game starts behaving differently: I backup first, then I uninstall the game, then I download and reinstall it, then play it and the game will show Player as the game name, I change it to something other than the game name I was using before the uninstall, and then the game will give a message that it detects that you have played on this device with a player at level xxx, whatever level you were before the uninstall, and asks if you want to use that version (I forget exact wording), and you accept that offer to use that player and you will be right back to where you were before the uninstall and, at least for me, the game issue that had appeared that caused me to do these steps has gone away. Note, I have had no issues with the updated game and have not done this to fix anything since the update. The gifting crash issue does not get fixed by this method, I stepped a friend through this and the crashing still occurred after the reinstall. Who knows, maybe the gem match issue can be resolved this way. Anyone willing to try it? Post back if you tried it and whether or not it did the trick or not. Also, I always ensure I have lots of free memory, like 4 or 5 GB free and nothing else running during the reinstall.

Posted on: May 10, 2014

Answer from: Carly
I'm having the same issue and did email support. So far no answer and no remedy from their tech team. Disappointing, I really enjoy this game.

Posted on: May 12, 2014

Answer from: Eemerald
This is the answer I received from support today. Thought you all would like to know.

Thank you for contacting us.We are very sorry for the frustration you have experienced. Please be informed that our Technical Team is aware of the issue and they are working on fixing it as quickly as possible. The update with the fix will be available in the nearest future. Please avoid reinstalling the app, as your game progress and purchased items will be lost.

We are thankful for your patience.
Please do not hesitate to reply if you have any other questions or concerns.

Best regards,
Julia Shkuratova| G5 Support Team

Posted on: May 12, 2014

Answer from: Della
Eemerald beat me to it... I received the same email from support. Hopefully they will have an update soon with the fix.

Posted on: May 13, 2014

Answer from: D'oh
Frustrating! I did the new update as was told to do, and Gem Match is Still crashing. I emailed them again, and got the generic answer. Is anyone else still having the problem?

Posted on: May 20, 2014

Answer from: Bella
Yes, I am having the same issue for about the past week. Very frustrating and it uses up a lot of energy points for nothing.

Posted on: May 29, 2014

Answer from: Lolo
Ditto. Wish I had never installed the update.

Posted on: Jun 6, 2014
Ask / All Questions »
Trailers & Gameplay Videos
View All Videos »
More Options
Games You May Like