Game Questions & Answers
iPhone - iPad Games

The Secret Society: Hidden Mystery Answers for iPhone - iPad

Home / iPhone - iPad /

Game Questions & Answers (Q&A) service lets you ask questions about video games for game consoles or PC games. So ask your The Secret Society: Hidden Mystery question for iPhone - iPad and get answers from real gamers or answer questions and share your insights and experience with the rest of the gaming community.

Boxshot & Details
The Secret Society: Hidden Mystery
  • Developer: G5 Entertainment
  • Publisher: G5 Entertainment
  • Genre: Adventure
  • Release: Nov 21, 2012
  • ESRB: Not Set

Question & Answers

Scatter lost time anomaly

Guys, I need your help. The picture shows the quest item, but there is no anomaly that I can see in the picture so I can't get the quest item- no matter how many times I try. What am I missing?

BettyBoop, Aug 14, 2014

Answer from: Aria
I answered this in detail, my internet connection dropped and now either my response didn't post and no one else has answered or I'm still seeing the old page and my internet hasn't properly goes nothing...

If you mean that the picture won't go to the desired anomaly, that happens to me too; I think it's just the game. I have been trying to get the Ancient Library in pairs mode for over 70 plays with zero luck - and I now have 3 quests for it!

If you mean the anomaly shows up, you play or banish but the item is never found, that happens too. Sometimes you have to play the picture many times in the right anomaly - once I even had an item simply drop while I was playing after it had sat in the quest queue for at least 2 months.

If you mean that you can see the item in the Can Be Found list but the picture is not in the correct anomaly setting, try this technique someone on this site mentioned - I have tried it successfully 3 times but sadly my finger usually clicks play before my brain kicks in to say, "let's hire a sleuth". ANYWAY, the technique suggested - when the item Can Be Found, even if the anomaly is incorrect, hire a friend, activate a Fortune Talisman and banish the anomaly. If the item doesn't show up, play immediately.

Good luck and hope I have answered your question!

Posted on: Aug 14, 2014

Answer from: BettyBoop
Aria, thank you for typing all that twice. My problem is the one you are having. I have 2 quest for the library that require me to scatter the lost time anomaly, but there is no lost time anomaly on it. I have been trying for days and can't figure out how I am going to get them.

Posted on: Aug 14, 2014

Answer from: BettyBoop
Aria! Thank you, thank you ,thank you! I hired a sleuth and got BOTH those quests.

Posted on: Aug 14, 2014

Answer from: RatSeeker
You may want to check the "can be found" in the library. I have noticed that even though I am supposed to scatter an anomaly, I can still find it when playing the pic- and have gotten it many times without actually having an anomaly. Otherwise, you do have to wait until the anomaly appears in that picture. Try playing the picture repeatedly and an anomaly may show up.

Posted on: Aug 14, 2014

Answer from: Asnyder959
Sometimes it works to scatter lost time in another pic and then go back to the room it requests and the quest will show ..

Posted on: Aug 14, 2014

Answer from: Julie
Ha! Betty, having a quiet laugh at your frustration that its not been there for days! I have had a quest in the palatial office for curse mode (please give me an anomaly, any anomaly will do!) for three months now. I have taken the damn room from 0% high seeker to 85% academic. I have ignored it for days on end, I have played every anomaly that comes up. I have pleaded with Christy that there is no shortage of lutes. But she will not hear of it. Only the lute from the office will do. I have fantasies that when I find that damn lute I will smash it over her head.

The game is frustrating. In many ways. I have a theory that maybe the game is a cover for secret government research into how much frustration one person / one group of people can absorb before they rise up. ;)

Posted on: Aug 14, 2014

Answer from: SunnyinFL
Betty, I was able to deal with the named anomaly in a different picture and then go to the named picture and find the item in the can be found list. Once it's available, hiring a sleuth and using a diamond horseshoe helped. If you don't have the Elegant Hats collection, just put them on your wish list and I will send you a set to multiply.

And to Julie - I Loved your answer! I'm still laughing!

PS. Send carrots. I'm fresh out!

Posted on: Aug 14, 2014

Answer from: Anita
Julie! I was ROFL at your post! I just about spat out my coffee i was laughing so much! I have soooo been there!

I have found that if you play the pictures around the one you need, then that will make an anomaly appear in your picture. So for the library, because it's on the edge of the desktop, play the pictures on the other side ( witches hut, Christmas Eve, tavern) and the ones to the right of the library can make the anomaly appear. I definitely recommend using a diamond horseshoe and a sleuth next time. Especially when it asks you to banish a particular anomaly. With a diamond horseshoe, often you can just banish any anomaly in the picture and it will give you the item.

Posted on: Aug 14, 2014

Answer from: BettyBoop
Julie, you are so right. You have me laughing at myself now. Great suggestions everyone. Next time I will have a plan of attack. Sunny and Anita, you two spoil me with your wonderful gifts. Thank you. Sunny, you are getting carrots until you tell me to stop :)

Posted on: Aug 14, 2014

Answer from: RobbiePC
I am still looking for the life in the curse mode in the palatial office too. I have played curse at least 10 times. I always use a golden horseshoe and have hired sleuths. Still no luck. Finally decided it would appear someday and quit stressing about it. Agree with Julie. Frustrating game

Posted on: Aug 15, 2014

Answer from: Itsuxbnme
Yeah, I don't have any diamond horseshoes. :-(

Posted on: Aug 16, 2014

Answer from: Itsuxbnme
Where do I get them?

Posted on: Aug 16, 2014

Answer from: Vikingchic
Hi Betty, I have had the same problems as mentioned by you and other posts here. There was some good advice here and I can't wait to try some.

@Itsuxbnme... There is are a few collections you can get the diamond horseshoe.
1) listening devices- needs 20 elements (5each) to combine and also the collection doesn't deplete from inventory.
2) legendary swords- needs 30 elements (10each) to combine
3) elegant hats- needs 48 elements (12each) to combine.

If you put any of these on your wl then multiply them you can have plenty. If you need any help getting them I will help, I just may have to send a couple of items a day since I am on a kindle. But I don't mind helping. Hope this helps. Btw...thanks to Gorlac I have found which collections are least costly (meaning quantity of elements to combine and if they deplete from inventory) for me and the giver the giver.

Posted on: Aug 17, 2014

Answer from: Anita
Here's the thread you were looking for Julie! Your post made me ROFL all over again!

Posted on: Oct 15, 2014
Answer this Question
Ask / All Questions »
Trailers & Gameplay Videos
View All Videos »
More Options
Games You May Like