Game Questions & Answers
iPhone - iPad Games

Car Escape 5 Answers for iPhone - iPad

Home / iPhone - iPad /

Game Questions & Answers (Q&A) service lets you ask questions about video games for game consoles or PC games. So ask your Car Escape 5 question for iPhone - iPad and get answers from real gamers or answer questions and share your insights and experience with the rest of the gaming community.

Boxshot & Details
Car Escape 5
  • Developer: Shanghai Hongju Network Technology Co., Ltd
  • Publisher: Shanghai Hongju Network Technology Co., Ltd
  • Genre: Adventure
  • Release: Jun 18, 2013
  • ESRB: Not Set

Question & Answers

Level 2 thermometer not working!

For some reason it wont let me use the thermometer in the glove box. Every time i click the thermometer it does not have a use button. The AC is set, rear aux is in, front aux cable is in, air is flowing at max. But it will not let me use the thermometer. I've tried restarting the game a few times and still no luck. Am I missing something or is this a glitch/bug in the game?

thatguy, Aug 20, 2013
Answers (Closed)

Answer from: lyn
There is a knob in the glovebox that you also have to turn. im not for sure if that helps. where did you find the cable for the rear aux?

Posted on: Aug 20, 2013

Answer from: Tac
The Therm. is only to set the Clock. see therm. reading example if one side shows 7 degree and the other 35 degree its 7:30

Posted on: Aug 20, 2013

Answer from: thatguy
I already turned the knob in the glove box to get the air blowing. the problem is that i cant place the thermometer in the glove box or view it to get the numbers needed to set the time. i also cant set the time if i had it, becuase it tells me the time is already adjusted and there is no need to mess with it anymore. this is uper annoying! lyn- the rear aux has three parts. the cable is in the back seat under the armrest, a card reader is in a slot right above the a/c controller, and the memory card is in the drawers under the dashboard a/c vents above the screen.

Posted on: Aug 21, 2013

Answer from: lyn
I think i might have a glitch in my game because that cable i used for the glovebox. ive seen other people complain about the same issue you are having also.

Posted on: Aug 21, 2013

Answer from: escapee
You are suppose to place the tissue in the glove box not the thermostat. Try looking in the left visor.

Posted on: Oct 5, 2013

Answer from: sadoerson
GUYS! this is not helping! ive been searching but everyone says the same thing! other people have said that theirs worked after restarting and stuff but it just wont work! Btw, thatguy, maybe we'll just have to delete this game and re-buy it cuz it appears to be un-functional with the thermomiter , dont worry i feel for u, this is such an annoying pain! I JUST WANNA FINISH LEVEL to see what happens next! .D:

Posted on: Dec 7, 2013

Answer from: Pro car escape
Now this number worked to me hope it works with you guys i think its 9:36

Posted on: Jan 25, 2014

Answer from: Demtro
The time that you set for Level 1 on the clock is different for everybody...

Posted on: May 24, 2014
Ask / All Questions »
More Options
Games You May Like