Game Questions & Answers
Playstation 3 Games

Assassin's Creed 3 Answers for Playstation 3

Home / Playstation 3 /

Game Questions & Answers (Q&A) service lets you ask questions about video games for game consoles or PC games. So ask your Assassin's Creed 3 question for Playstation 3 and get answers from real gamers or answer questions and share your insights and experience with the rest of the gaming community.

Boxshot & Details
Assassin's Creed 3
  • Developer: Ubisoft
  • Publisher: Ubisoft
  • Genre: Action Adventure
  • Release: Oct 30, 2012
  • ESRB: Mature

Question & Answers

Help on sequence 2 "shoot the barrels"

I can not get the musket or the pistol to fire on the barrels in this sequence. I have played this sequence several times, sometimes the game will give me a musket, sometimes not. It will let me reload the musket and aim the musket but will not let me fire. It will not even let me draw my pistol to fire either. HELP IF ANYONE KNOWS ANYTHING.

chilly 1234, Nov 1, 2012
Answers (Closed)

Answer from: Midnite
Same problem here. They say to download the patch to fix all the bugs. I did download it. And still have the same problem. Can someone please grant us your guidance? Much obliged.

Posted on: Nov 1, 2012

Answer from: Devlin
Aim under the wagon at the barrels on the floor, they will light up white and you can shoot them. Then the game will continue :)

Posted on: Nov 2, 2012

Answer from: Django
Same thing here except when I try aiming below the barrels nothing gets highlighted. Major glitching. Looks like I'm stuck on this till its sorted.

Posted on: Nov 2, 2012

Answer from: Addy
I can't reload the musket or aim it. I've tried for over a hour I'm getting extremely frustrated

Posted on: Nov 3, 2012

Answer from: tekntonk
Umm... This is ridiculous. Is there a way to fix this, or...? Aiming at the kegs on the ground does not turn them white (or highlight / select them) for me. Aiming the red reticule does nothing.

Posted on: Nov 3, 2012

Answer from: ash
Hi there is no patch for this use white marker instead of red and it will shoot the barrels i was struck on this level for 1 hrs and figured out that it was white instead of red hope this help

Posted on: Nov 4, 2012

Answer from: Fred
And how do you change the marker from red to white?

Posted on: Nov 4, 2012

Answer from: HCT
Im playing on the xbox and i had it would by holding Y which turns you into the shooting stance, sort of what they did for parrying. Anyway it should translate to triangle. See if that does anything.

Posted on: Nov 5, 2012

Answer from: bio_inked_skin6
It took me 20 minutes but I eventually went into eagle vision and just started pressing triangle franticly and it shot.

Posted on: Nov 5, 2012

Answer from: erlonslady
It took me forever to figure out, but on a PS3 hold the L1 and move your camera around until whatever you are trying to shoot lights up. You may need to get closer, walk around a bit, but once it lights up you can shoot. Pain in the butt! There are no hash marks or any aid to assist in "targeting" with a musket. It's just blind luck that your camera passes over the obscure "point" the games considers the target.

Posted on: Nov 6, 2012

Answer from: hawk
For people that got through this glitch, could you walk? cuz i can only spin in place.

Posted on: Nov 6, 2012

Answer from: farmer275
Focus on the guard on top of the wall use eagle vision this should change your marker to white instead of shooting him aim back at the barrels and shoot them.

Posted on: Nov 7, 2012

Answer from: chilly 1234
I did a SYSTEM update and still the same problem. I was stuck until I put the red cursor on the guard over the door, (this took a while due to the camera angle), and turned on my eagle vision, then after about 30 seconds the cursor highlighted the barrels below the carraige and I could finally shoot it.

Just wait till you get to the "storage" screen, when you are Conner. Had to shut my system off 2 times before I could advance. It says the "O" button is supposed to back out, but the only way to get the game to move on is to send a wagon train to somewhere. This game is even glitchier than the last one!

Posted on: Nov 8, 2012

Answer from: Jonboy13
You have to shoot the guy on the wall first and then aim at the barrels and they will turn white then press Y n hey presto...took me 30min 2 work it out :-/

Posted on: Nov 9, 2012

Answer from: Bigjaydogg
Make sure the "aiming cursor" is on target. It is a hard to see little circle. If that is not aimed at your target you cannot fire

Posted on: Nov 9, 2012

Answer from: Anonymous
Aim your red dot up and a white dot will appear on the barrel, then shoot. That worked for my dad. He was stuck also.

Posted on: Nov 11, 2012

Answer from: Brawny
Shoot the guard then hold the triangle to reload the musket. You should get a white target to aim at te bottom barrel.

Posted on: Nov 12, 2012

Answer from: lorshadow
It depends on which system u have it for but for ps3, kill the guard then aim at the barrel and press triangle but u may have to wait for player to reload

Posted on: Nov 15, 2012

Answer from: TheOliverGrundy
4th attempt was a charm :( - (PS3) - this was the first time I had the musket offered on the ground to actualy shoot with - this was also the first time that I had gotten to the gate with the musket actualy in my hand ( I had previously switched to swords during combat) so this may be a factor.

Other than that - there were no 'white markers' just kept pressing the triangle and aiming around the bottom of the barrow, slightly to the right towards the gate and it just happened after a few seconds - I can't say why (was definately infuriating!)

Good luck :)

Posted on: Nov 18, 2012

Answer from: Roosy
We had to aim 2 meters left of the man on the wall for him to light up, and then 2 meters left of the barrels, you are not aiming from his eyes. Then u can shoot

Posted on: Dec 1, 2012

Answer from: Promei
If you replay the Welcome to Boston memory, all the special weapons will be available for Haytham in the general store. Buy them, then reload last checkpoint, then go back in the store and buy the weapons required for mission, then just re-equip the nice weapons b4 you leave. Haytham will have them, sword excluded, on the later missions you replay

Posted on: Dec 6, 2012

Answer from: JAZZCON
If you do not have a rifle, restart the whole mission. This time use the q key and the f key and the rifle to shoot the guard on the wall and kill him. Then use q and f keys on the PC version to shoot the barrels under the cart.

Posted on: Dec 13, 2012

Answer from: sully
Let me just say that I am super disappointed. I have been at this juncture for over an hour, I have tried every single thing said above and nothing is working. If it doesn't work soon this game will go in the trash and I will never buy ubisoft again. I'm using a ps3, I cannot shoot the rifle at the guard or the barrels.

Posted on: Dec 27, 2012

Answer from: bbyprincess
There is only one barrel that lights up and its the one on the right that is why it is so hard. good luck with ur gaming hope this helps

Posted on: Jan 3, 2013

Answer from: tony
I had to restart the mission a few times before i got it to work. Remember you have to kill the last guard with a rifle for it to work.

Posted on: Jan 7, 2013

Answer from: fk_Ubi
Ok i had the same problem and i figured it out (PC)

Actually the white outline is supposed to show on the barrel but it does not. Obviously its buggy. So i did it by NOT aiming with the F key on the barrel, but rather moving away from it from left and very slowly moving the mouse towards the right. At some point it will start highlighting the barrel in white and then you can press Q. If its not highlighted in whiteoutline pressing Q will have no effect. Ok so once you blow the barrel and on the way back you have to shoot npc's on the roof same way. pretty pathetic control system (thank ubisoft)

Posted on: Feb 24, 2013

Answer from: apoc666
Turn the brightness down so you can see the cursor, then aim underbthe barrel

Posted on: Feb 25, 2013

Answer from: Assassin.
Just look closely, I had the same problem but there is a target that looks exactly like the red one but its white so its hard to see, put the white one over the bottom barrel and shoot with either the musket or pistol. Doesn't matter.

Posted on: May 7, 2013

Answer from: Bdiz
Ive been restarting this Mission like 10 times and I can't shoot the Muskett. I don't know why I can't, because I shot the guards just fine. I just got it to reload this time after 10 times I'm not being able to shoot and I still can't shoot!

Posted on: Feb 13, 2014
Ask / All Questions »
Trailers & Gameplay Videos
More Options
Games You May Like