Game Questions & Answers
Xbox 360 Games

The Elder Scrolls 5: Skyrim Answers for Xbox 360

Home / Xbox 360 /

Game Questions & Answers (Q&A) service lets you ask questions about video games for game consoles or PC games. So ask your The Elder Scrolls 5: Skyrim question for Xbox 360 and get answers from real gamers or answer questions and share your insights and experience with the rest of the gaming community.

Boxshot & Details
The Elder Scrolls 5: Skyrim
  • Developer: Bethesda Game Studios
  • Publisher: Bethesda Softworks
  • Genre: Role-Playing
  • Release: Nov 11, 2011
  • ESRB: Mature

Question & Answers

Rings wont turn in bleak falls barrow

I am at the final door in bleak falls barrow. i have the journal and i have the claw. when i push "a" to move the rings nothing #*^@ happens! has anyone else had this problem? do i have to start all over? thank you.

Jtinz, Nov 15, 2011
Answers (Closed)

Answer from: TillerRider
Just save your game and reboot. didn't happen to me but to a friend of mine

Posted on: Nov 16, 2011

Answer from: Lucio
Leave the room i think thats what i did then click on the rings before yu use the claw

Posted on: Nov 16, 2011

Answer from: Malaki
I can't turn rings either. i left the room came back didn't work. i play on 360 i rebooted and still does not turn. claw turns bu not rings.

Posted on: Nov 21, 2011

Answer from: Pandora
I had this problem as well the rings wouldn't turn i went back out (actually went all the way back to riverrun but i don't think that's necessary!) save your game, restart your game and then go back in worked for me!! good luck

Posted on: Nov 27, 2011

Answer from: frustratedDad
Just leave the dungeon and reenter. seems to reset the pillars.

Posted on: Dec 6, 2011

Answer from: Victim232
Hit me to. As long as the rings were all turned to an OWL when I got there, they were immobile and locked. I had to load a previous autosave (from entering the dungeon in the first place) and do it ALL over again. When I got there the second time and the wheels were in the proper spots and movable. I've done dozens of character starts -- always run thru this dungeon. 3 times this has happened. Whatever bug it is it doesn't happen often.

Posted on: Sep 14, 2012

Answer from: ali cat
Leaving the dungeoun didn't work for me, I also had to start from a previous save, but i go by the rule that if it looks like your going into something important, save first. less annoying if you die, and apparently less annoying for glitches too :P

Posted on: Dec 5, 2012

Answer from: JPlay777
For me i just went back to the other side of the bridge and saved then reloaded my game, worked fine

Posted on: Mar 16, 2014

Answer from: Apocolypse
Well, the same problem has happened to me, gone out of the room and back. Gone back to a previous save, all of whats suggested, and it still doesnt turn :/ please help :(

Posted on: Mar 20, 2014
Ask / All Questions »
Trailers & Gameplay Videos
More Options
Games You May Like